Python 开发环境

Summary: Author: 张亚飞 | 阅读时间: 1 minute read | Published: 2016-08-14
Filed under Categories: LinuxTags: Note,

Python 安装

MacOS 默认安装的是 Python2.7 旧版本,为了研究 TensorFlow 需要安装 Python3 最新版

查看系统当前版本,发现有好几个版本,其中Current目录为当前系统的python版本.

$ ls /System/Library/Frameworks/Python.framework/Versions
2.3  2.5  2.6  2.7  Current

还有另一个目录

$ ls /usr/local/Frameworks/Python.framework/Versions
3.7

首先使用系统自带的 Homebrew 查看是否有 Python3 版本

$ brew search python3
==> Formulae
boost-python3                                               python3 ✔                                                   python@3 ✔                                                  python@3.8

If you meant "python3" specifically:
It was migrated from homebrew/cask to homebrew/core.

可以看到,有一个 python@3.8 的版本

已经存在,我们可以直接安装了:

brew install python@3.8

Comments

Cor-Ethan, the beverage → www.iirii.com